LinuxPedia

Wiki libre et indépendant dédié à GNU-Linux et BSD.

Outils pour utilisateurs

Outils du site


frugalware:mise_a_jour_version_stable

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

frugalware:mise_a_jour_version_stable [2018/11/17 13:53] (Version actuelle)
Ligne 1: Ligne 1:
 +====== Mettre à jour vers la nouvelle version stable ======
 +{{ :​frugalware_dark.png?​nolink&​100 }}
 +  *//​[[http://​www.frugalware.org/​docs/​stable/​upgrade.html|Article original]]//​\\ ​
 +<WRAP info>​Tous les 6 mois une nouvelle version stable est mise à disposition,​ cette page vous indiquera comment mettre à jour votre ancienne version stable vers la nouvelle.
 +</​WRAP>​
  
 +===== 1. Préambule =====
 +
 +Le but de ce tutoriel est de vous montrez comment mettre à niveau votre système **Frugalware 1.9** (//​Arcturus//​) vers **Frugralware 2.0** (//Rigel//)
 +
 +=====2. Désinstallation des paquets devenus obsolètes =====
 +
 +Certains paquets ne seront pas désinstallés automatiquement pour cause de dépendances strictes. Si vous rencontrez durant la mise à niveau du système un message tel que celui-ci:
 +
 +<​code>::​ foobar-subpkg:​ requires foobar=1.0.0</​code>​
 +
 +Alors vous devrez effectuer pour chaque paquet enlevé la commande suivante:
 +
 +<​code>​pacman-g2 -Rd <​PAQUETS></​code>​
 +
 +<​PAQUETS>​ doit être remplacé par les noms de chaque paquets enlevés. Ceci doit être effectué en priorité sur le système à mettre à niveau.
 +
 +===== 3. pacman-g2 =====
 +
 +Cette nouvelle version arrive avec une amélioration de **pacman-g2**,​ vous devez tout d'​abord l'​installer:​
 +
 +<​code>​pacman-g2 -Sy pacman-g2</​code>​
 +
 +===== 4.Mettre à niveau le système =====
 +
 +Maintenant il est temps de mettre à niveau le système lui-même:
 +
 +<​code>​pacman-g2 -Su
 +:: Starting local database upgrade...</​code>​
 +
 +Il vous sera demandé de remplacer certains paquets automatiquement. Ceci est normal et il est attendu que vous répondiez O (pour Oui) à ces questions (ou en appuyant simplement sur la touche ENTREE).
 +Ensuite la liste de paquets à mettre à niveau apparaîtra. Appuyez sur ENTREE et patientez. Faîtes un peu de thé, cela peut prendre du temps :-)
 +
 +===== 5. Mettre à jour les fichiers de configuration =====
 +pacman-g2 ne touche pas aux fichiers de configuration si vous les avez personnalisé. Vous devrez lancer: ​
 +
 +<​code>​find /etc -name '​*.pacnew'</​code>​
 +
 +et mettre à jour chaque fichier de configuration basé sur la version **.pacnew**. Une fois terminé avec l'un d'eux vous devrez supprimer le fichier **.pacnew**.
 +
 +===== 6. Mise à jour de bind =====
 + ​L'​exemple de configuration mise en cache que nous fournissons dans le paquet de **bind** est mis à jour, et **named.ca** est renommé **named.root**. Si vous construisez votre configuration sur cet exemple, assurez-vous de mettre à jour votre fichier **named.conf**.
 +
 +===== 7. Le redémarrage =====
 +Maintenant que le noyau est également mis à niveau vous devez redémarrer votre machine.
 +
 +Voilà! C'est terminé!
frugalware/mise_a_jour_version_stable.txt · Dernière modification: 2018/11/17 13:53 (modification externe)