LinuxPedia

Wiki libre et indépendant dédié à GNU-Linux et BSD.

Outils pour utilisateurs

Outils du site


frugalware:stable_vers_current

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

frugalware:stable_vers_current [2018/11/17 13:53] (Version actuelle)
Ligne 1: Ligne 1:
 +====== Passer de "​stable"​ à "​current"​ ======
  
 +
 +//Vous venez d'​installer Frugalware en version stable et vous désirez passer en current afin d'​avoir les paquets les plus récents: la dernière version de firefox, de thunderbird,​ des drivers, du kernel...etc. Attention la branche -current n'est pas recommandée pour les machines de production//​
 +
 +=== Modification de pacman.conf ===
 +
 +
 +Rien de ne plus simple, il vous suffit en root d'​editer le fichier **/​etc/​pacman-g2.conf** de cette façon:
 +
 +  #  nano /​etc/​pacman-g2.conf
 +
 +Dans le fichier commentez la ligne des paquets stable et décommentez celle des paquets current, voilà à quoi doit ressembler cette partie dans votre fichier:
 +
 +<php>
 +# -current
 +Include = /​etc/​pacman.d/​frugalware-current
 +
 +# -stable
 +#Include = /​etc/​pacman.d/​frugalware
 +</​php>​
 +
 +Sauvegarder votre fichier. ​
 +
 +=== Mise à jour avec les paquets de la branche current ===
 +
 +
 +Puis faites synchroniser pacman avec la branche current:
 +
 +  #  pacman-g2 -Sy
 +
 +Mettez à jour pacman:
 +
 +  #  pacman-g2 -S pacman
 +
 +Mettez à jour votre système:
 +
 +  #  pacman-g2 -Su
 +
 +Voilà vous etes en current ! :-D
frugalware/stable_vers_current.txt · Dernière modification: 2018/11/17 13:53 (modification externe)