LinuxPedia

Wiki libre et indépendant dédié à GNU-Linux et BSD.

Outils pour utilisateurs

Outils du site


internet:skype

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

internet:skype [2018/11/17 13:53] (Version actuelle)
Ligne 1: Ligne 1:
 +====== Skype ======
 +{{:​skypelogo.png?​nolink}}\\ \\ 
 +<​note>​Skype est gratuit, mais n’est pas un logiciel libre : son code source est propriétaire,​ et ne peut être modifié.</​note>​
 +==== Présentation ====
 +Et oui le célèbre logiciel **Skype** existe sur **GNU-Linux**. Il vous est possible ainsi de discuter en visuel avec quelqu’un par ordinateur ou encore de faire des conférences à plusieurs mais dans ce cas pas d’image.\\ ​
 +Bonne discussion.\\ \\ 
 +Les paquets des dernières versions pour GNU-Linux se trouvent sur les sites suivants :
 +  *[[http://​www.skype.com/​intl/​en/​download/​skype/​linux/​|skype.com]]
 +  *[[http://​rpm.pbone.net/​|rpm.pbone.net]]\\ \\ 
  
 +----
 +==== INSTALLATION ====
 +  *Via votre [[:​utilitaires_configuration#​installation_de_logiciel|Gestionnaire de paquet]].
 +  *Via un [[:​utilitaires_configuration#​les_consoles|terminal]].
 +== Sous Pardus ==
 +  $ sudo pisi it skype  ​
 +== Sous Frugalware ==
 +  # repoman m skyper
 +== Sous gentoo / Sabayon ==
 +   # emerge skype
 +== Sous Debian / Ubuntu ==
 +
 +Skype est présent dans les dépôts "​partners"​ d'​Ubuntu,​ veillez à activer ces dépôts dans votre fichier /​etc/​apt/​sources.list ou via le gestionnaire de paquets "​Synaptic"​. La ligne du fichier "​sources.list"​ sera :
 +
 +<​file>​deb http://​archive.canonical.com/​ubuntu lucid partner</​file>​
 +
 +Remplacez "​lucid"​ par votre version (Skype n'est disponible qu'à partir de Lucid sur ce dépôt).
 +
 +Une fois le dépôt ajouté utilisez :
 +
 +<​code>​sudo apt-get update
 +sudo apt-get install skype</​code>​
 +
 +Skype est disponible en version x86 (32bit) ou x86_64 (64bits ou "​amd64"​).\\
 +
 +Alternativement vous pouvez télécharger Skype sur [[http://​www.skype.com/​intl/​fr/​get-skype/​on-your-computer/​linux/​|la page dédiée du site Internet]]. Installez le paquet "​.deb"​ téléchargé avec un logiciel comme "​gdebi",​ ou utilisez la ligne de commande :
 +
 +<​code>​sudo dpkg -i skype-version.deb</​code>​
 +
 +Où "​skype-version.deb"​ sera évidemment à remplacer par le nom du paquet téléchargé.
 +
 +Sur cette même page du site Internet de Skype sont également disponibles des paquets pour Debian, uniquement en version 32bits à ce jour. Skype étant un logiciel non-libre, au fonctionnement opaque, il n'est pas présent dans les dépôts Debian.
 +
 +== Installer Skype sur Debian x86-64 ==
 +
 +<​note>​ Skype n'est pas un logiciel libre, son code source n'est pas accessible ni encore moins modifiable, et son fonctionnement est opaque. Cette procédure vise seulement à lever un obstacle souvent évoqué pour passer à l'​architecture 64bit, pas à faire la publicité de Skype.\\
 +Si vous utilisez cette procédure (ou une autre) merci de prendre le temps de laisser un message sur le [[http://​forum.skype.com/​index.php?​showforum=18|forum Skype Linux]] demandant la création d'une version 64bit, ou encore mieux en suggérant que si les sources étaient ouvertes la communauté s'en serait occupée depuis longtemps.</​note>​
 +
 +<note warning> Cette utilisation de paquets Ubuntu sur Debian n'est supportée ni par Debian ni par Ubuntu, si vous avez un problème pas la peine de poster sur une liste d'aide ou un forum ! Utiliser cette astuce pour d'​autres paquets est une très mauvaise idée... Cela dit si ça ne fonctionne pas vous pouvez toujours essayer [[http://​www.linuxpedia.fr/​forum/​index.php?​action=pm;​sa=send;​u=15|d'​envoyer un message au mainteneur du tutoriel]](mais il n'aime pas Skype ;-) )</​note>​
 +
 +L'​objectif est juste d'​installer Skype de la manière la plus simple possible sur un système [[debian:​debian|Debian]] x86-64, sans chroot 32bit. L'​installation a été testée sur Debian Squeeze amd64 (paquets version "​Lucid"​).
 +
 +Pour ça il faut juste installer les librairies de compatibilité **ia32-libs**,​ récupérer le dernier paquet [[http://​archive.canonical.com/​ubuntu/​pool/​partner/​s/​skype/​|Skype]] sur les dépôts "​partners"​ d'​Ubuntu,​ et l'​installer avec les dépendances dont la plupart sont déjà satisfaites par les librairies de compatibilité ia32-libs.
 +
 +Pour information les dépendances sont :
 +
 +  * ia32-libs
 +  * lib32asound2
 +  * lib32gcc1
 +  * lib32nss-mdns,​ lib32stdc++6
 +  * libc6-i386
 +
 +Toutes sont disponibles sur Squeeze.
 +
 +Vous pouvez installer les paquets téléchargés avec la commande ​ "dpkg -i", ou le programme "​**gdebi**"​ qui a l'​énorme avantage de vérifier la présence des dépendances.
 +
 +C'est tout, si votre web-caméra est correctement configurée à vous la vidéo-conférence (testé avec Quickcam Logitech pro 9000 et Creative Live! AF, pilote uvc, ainsi que Quickcam Communicate stx, pilote gspca).
 +
 +
 +Alternativement vous pouvez télécharger le dernier paquet en architecture "​amd64"​ prévu pour Ubuntu depuis [[http://​www.skype.com/​intl/​fr/​get-skype/​on-your-computer/​linux/​|le site de Skype dédié à Linux]]. Vous aurez besoin des mêmes dépendances,​ l'​installation se passe de la même façon.\\
 +
 +Si ces procédures échouent, il reste à essayer la version "​Dynamic-Static"​ disponible sur le site de Skype. L'​archive au format "​.tar.gz"​ doit être décompressée,​ par exemple dans /opt, et l'​exécutable "​skype"​ qu'​elle contient doit être lancé manuellement.
 +
 +----
 +
 +==== Liens ====
 +  *[[http://​www.skype.com/​intl/​fr/​|Site officiel]]
 +  *[[http://​doc.ubuntu-fr.org/​skype|Page sur Ubuntu-fr]]\\ \\ 
 +
 +----
 +//Créé par ang1fr comme sur alionet.org//​
internet/skype.txt · Dernière modification: 2018/11/17 13:53 (modification externe)