LinuxPedia

Wiki libre et indépendant dédié à GNU-Linux et BSD.

Outils pour utilisateurs

Outils du site


opensuse:install_codecs_proprietaires

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

opensuse:install_codecs_proprietaires [2018/11/17 13:53] (Version actuelle)
Ligne 1: Ligne 1:
 +======Installation des codecs propriétaires======
  
 +=====Installation par méta-paquet=====
 +
 +Comme souvent, l'​installation des codecs propriétaires est plus simple si on utilise un one click install. Bien entendu, le méta paquet dépend de la version :
 +
 +  * [[http://​software.opensuse.org/​search?​baseproject=openSUSE%3A11.2&​p=1&​q=opensuse-codecs-installer|Pour la 11.2]]
 +  * [[http://​software.opensuse.org/​search?​baseproject=openSUSE%3A11.1&​p=1&​q=opensuse-codecs-installer|Pour la 11.1]]
 +
 +
 +=====Installation par YaST=====
 +
 +L'​installation est également possible en utilisant le gestionnaire de logiciels de YaST. Ajoutez le dépot OSS, qui fait partie des dépôts communautaires. Une fois fait, cherchez le paquet : 
 +
 +<​code>​opensuse-codecs-installer</​code>​
 +
 +dans l'​installateur de paquet de YaST, et installez le :)
 +
 +=====Installation par zypper=====
 +
 +Encore une fois, il faut commencer par ajouter le dépôt OSS. Vérifiez d'​abord s'il n'est pas dans votre liste, en exécutant en root (pour la 11.2) :
 +
 +<​code>​zypper lr -u|grep http://​download.opensuse.org/​distribution/​11.2/​repo/​oss/</​code>​
 +
 +Si la commande ne vous renvoie rien, ajoutez le dépôt en faisant :
 +
 +<​code>​zypper ar http://​download.opensuse.org/​distribution/​11.2/​repo/​oss/</​code>​
 +
 +Le dépôt installé, il ne manque plus que les codecs :
 +
 +<​code>​zypper in opensuse-codecs-installer</​code>​
 +
 +=====Un peu de détails=====
 +
 +En fait, OCI (One Click Install) va ajouter un ou deux dépôts (Packman à coup sur), installer quelques paquets, changer le fournisseur de quelques autres. Nous allons ainsi ajouter à notre installation w32codec-all,​ libdvdcss, la version de libxine provenant de Packman, ainsi que la version de notre lecteur (amarok ou gstreamer) provenant de Packman, de sorte que tout ça marche bien ensemble. C'est faisable à la main, mais on a vite fait d'​oublier un paquet. D'​ailleurs,​ j'en ai peut être oublié... ;)
opensuse/install_codecs_proprietaires.txt · Dernière modification: 2018/11/17 13:53 (modification externe)