LinuxPedia

Wiki libre et indépendant dédié à GNU-Linux et BSD.

Outils pour utilisateurs

Outils du site


opensuse:gnome3

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

opensuse:gnome3 [2018/11/17 13:54] (Version actuelle)
Ligne 1: Ligne 1:
 +====== Upgrade de Gnome3 sur OpenSUSE 11.4 ======
  
 +OpenSUSE 11.4 est sortie avec la version 2.32 de Gnome par défaut.Voici la procédure d'installation de Gnome3 sur cette version d'OpenSUSE:
 +
 +  * [EN]http://en.opensuse.org/openSUSE:GNOME_3.0
 +  * [EN]http://www.brighthub.com/hubfolio/matthew-casperson/blog/archive/2011/04/25/installing-gnome-3-over-a-kde-based-opensuse-11-4-installation.aspx
 +
 +Pour tout problème,n’hésitez pas à poser vos questions sur [[http://www.alionet.org|www.alionet.org]]
 +
 +===== One-click install (recommandé) =====
 +
 +Premièrement,vérifiez que vous avez un terminal d'ouvert pour rebooter la machine après l'upgrade,fermez toutes les autres applications.
 +
 +{{:opensuse:oneclick.png?200|}}\\
 + [[http://widehat.opensuse.org/repositories/GNOME:/STABLE:/3.0/openSUSE_11.4/gnome3-32bit.ymp|Pour 32bit]]
 +[[http://widehat.opensuse.org/repositories/GNOME:/STABLE:/3.0/openSUSE_11.4/gnome3-64bit.ymp|Pour 64bit]]
 +
 +Suivre les instructions sur l'écran, une fois l'upgrade terminé tapez la commande suivante dans le terminal:
 +
 +    $ sudo /sbin/reboot
 +    
 +Si vous avez oublié de l'ouvrir faites un click droit sur le bureau , "ouvrir un terminal"
 +
 +===== Upgrade en ligne de commande =====
 +
 +Si vous aimez la ligne de commande, voici ce que vous devez faire en root après avoir fermé toutes les applications:
 +
 +Ajoutez le dépot GNOME:STABLE:3.0
 +     # zypper ar obs://GNOME:STABLE:3.0/openSUSE_11.4 GNOME_STABLE_3.0 
 +
 +Configurez le dépôt pour qu'il soit en auto refresh et attribuez lui une priorité plus grande que les autres dépots OpenSUSE 11.4
 +     # zypper mr -p 98 -r GNOME_STABLE_3.0 
 +
 +Faites l'Upgrade ( vérifiez que toutes les applications sont bien fermées)
 +     # zypper dup
 +
 +Assurez vous que GNOME Shell and GNOME3 theme sont bien installés:
 +     # zypper in gnome-shell metatheme-adwaita-common 
 +
 +Quand l'upgrade est complet, rebootez votre système :
 +     #reboot 
 +
 +===== Pour les Utilisateurs de OpenSUSE 11.4 avec KDE par défaut =====
 +
 +il vous faut rajouter quelques packages si vous voulez que ça fonctionne:
 +
 +  * Lancez en ligne de commande
 +  sudo yast2 
 +  * allez dans logiciel --->installer/supprimer des logiciels 
 +  * Dans le filtres mettez rechercher et rechercher GNOME3
 +  * désinstallez les packages qui sont en conflit avec gnome-menus-branding-openSUSE
 +  * appliquez les changements
 +
 +il devrait vous installer des packages qui vous permettront d'avoir un GNOME 3 fonctionnel.
 +
 +
 +
 +===== FAQ =====
 +
 +**J'ai upgradé et j'ai trouvé un bug, à qui dois-je m'adresser ??**
 +
 +Veuillez poster un rapport de bug [[https://bugzilla.novell.com/ICSLogin/?%22https://bugzilla.novell.com/ichainlogin.cgi?target=enter_bug.cgi?classification%3D28%26product%3DopenSUSE%252011.4%26submit%3DUse%2520This%2520Product%22|ici]] avec [GNOME3] dans le sujet.
 +
 +**J'ai installé Gnome3 via  le LiveCD comment puis-je avoir les dernières versions de mise a jour GNOME ??**
 +
 +Vous devez changer le dépôt de GNOME pour le remplacer par GNOME:STABLE:3.0 voici la procédure:
 +
 +Ajoutez le dépôt GNOME:STABLE:3.0
 +     # zypper ar obs://GNOME:STABLE:3.0/openSUSE_11.4 GNOME_STABLE_3.0 
 +
 +Configurez le dépôt pour qu'il soit en auto refresh et attribuez lui une priorité plus grande que les autres dépôts OpenSUSE 11.4
 +     # zypper mr -p 98 -r GNOME_STABLE_3.0 
 +
 +Supprimez l'ancien dépôt :
 +     # zypper rr home:fcrozat:gnome3_11.4
 +
 +Faites l'Upgrade ( vérifiez que toutes les applications sont bien fermées)
 +     # zypper dup
 +
 +Quand l'upgrade est complet, rebootez votre système :
 +     #reboot 
 +
 +===== Bugs Connus =====
 +
 +  * Liste à puce GNOME Shell requiert le support 3D (openGL) qui n'est pas encore assez stable avec VirtualBox et VMWare. OpenSUSE recommande de désactiver le support 3D dans ce contexte. 
 +  * NetworkManager 0.9, requis par GNOME 3, connait les problèmes suivants:
 +         *KDE4 ne détecte plus les paramètres réseau, vous devez passer par ifup en passant par Yast (devrait être corrigé dans la prochaine version d'OpenSUSE )
 +         *Activer des réseau wifi WPA n'est pas possible depuis GNOME SHELL ou le Centre de contrôle du réseau. Ce problème devrait être réglé rapidement
 +         *Novellvpn n'est pas supporté, pour le moment pas de solution
 +         *Le mot de passe root est demandé lors de la création de profils WEP/WPA
 +  * La configuration de l'autologin via le "User Account panel" n'est pas bonne .Passez directement par yast
 +  * Le mot de passe root est demandé pour chaque mise à jour des dépôts lors d'alertes de sécurité
 +
 +
 +have fun!
opensuse/gnome3.txt · Dernière modification: 2018/11/17 13:54 (modification externe)