LinuxPedia

Wiki libre et indépendant dédié à GNU-Linux et BSD.

Outils pour utilisateurs

Outils du site


opensuse:probleme_version_zypper

Corriger les problèmes de version de zypper

Première approche

Proposée par Oh!Rocks sur Alionet :

  • Passer en root .
  • Entrer dans le répertoire /usr/lib (si tu es en 32 bits) ou dans /usr/lib64 (si tu es en 64 bits) :
cd /usr/lib 
  • Lister le contenu (maximise la fenêtre pour mieux voir) : ls
  • Chercher un fichier qui doit s'appeler libzypp.so.631.0.4 ou quelque chose d'approchant au niveau des numéros ;
  • On va faire un lien symbolique entre le fichier non trouvé et celui que tu as repéré :
 ln -s libzypp.so.631.0.4 libzypp.so.619 

Attention à l'ordre ;)

On peut alors reprendre la mise à jour, ou plus simplement réutiliser zypper ou YaST ! :)

Seconde approche

Une méthode “plus propre” a été proposée par Chrysnatine sur le chan officiel d'openSUSE. Elle propose de récupérer directement le rpm de zypper au bon endroit, de l'installer comme suit : (en root)

rpm -Uvh http://download.opensuse.org/update/11.2/rpm/x86_64/zypper-1.3.4-0.1.3.x86_64.rpm

Cette solution a l'air de corrompre la base de données des rpm… mais pas de panique, on va faire un petit

rpm --rebuiddb

Amusez-vous bien !

opensuse/probleme_version_zypper.txt · Dernière modification: 2018/11/17 13:54 (modification externe)