LinuxPedia

Wiki libre et indépendant dédié à GNU-Linux et BSD.

Outils pour utilisateurs

Outils du site


pilotes_ati_pardus

Pilotes ATI

Les derniers drivers fglrx supportent les Radeon 9500+ et les X-series cards jusqu'aux X1900.

Disable Composite Extension

Par défaut “Composite extension” est activé, néanmoins, fglrx ne supporte pas encore “Composite avec DRI”. Nous allons devoir désactiver “Composite”, pour cela nous devons modifier le fichier xorg.conf :

sudo kate /etc/X11/xorg.conf

Ajoutez à la fin du fichier :

Section "Extensions"
       Option  "Composite" "Disable"
EndSection

Pour les autres modifications nous utiliserons nano .

sudo nano /etc/X11/xorg.conf

Installation des pilotes via Pardus Way

 sudo pisi it http://paketler.pardus.org.tr/pardus-2007-test/ati-drivers-8.40.4-21-24.pisi

Configuration des pilotes

  • Note: Pour la configuration des pilotes nous avons une alternative, editez votre /etc/X11/xorg.conf et remplacez “ati” par “fglrx” dans la section “Device” . En utilisant cette méthode vous ne perdrez pas vos anciens paramètres “Screen” et “Monitor” . Après cela vous pouvez utiliser aticonfig pour les paramètres . L'alternative à cette méthode est aticonfig –initial – .
sudo aticonfig --initial

Et puis :

sudo aticonfig --overlay-type=Xv
  • Note: Ceci est une alternative à la précedente étape

Finaliser l'installation :

Maintenant, sauvegardez tout vos fichiers d'ouvert, et rebootez le système :

sudo shutdown -r now
  • Note: Néamoins le reboot n'est pas obligatoire, il suffit de redémarrer X en appuyant simultanément sur CTRL+ALT+BACKSPACE . Néamoins le redémarrage de votre ordinateur est conseillé .

Vérifications

Pour s'assurer que le pilote fglrx est correctement installé ouvrez un terminal, puis :

$ sudo fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON 9600/9700 Series
OpenGL version string: 2.0.6650 (8.40.4)

Vous devriez lire “ATI” et non “Mesa” .

Si vous lisez ce message 'Xlib: extension “XFree86-DRI” missing on display “:1.0”' Assurez vous d'avoir ajouté au fichier /etc/X11/xorg.conf ceci :

Section "Extensions"
   Option "Composite" "Disable"
EndSection

Désormais vous disposez de Ati tools pour configurer votre PC .

pilotes_ati_pardus.txt · Dernière modification: 2018/11/17 13:54 (modification externe)